Apple blokkeert opnieuw Java plug-in

Apple blokkeert sinds deze week verouderde versies van Java 6 en Java 7. Dit is al voor de derde keer dit jaar dat een dergelijke actie door Apple wordt genomen vanwege beveiligingsissues. Mac gebruikers die een oudere versie van Java hebben draaien worden daardoor gedwongen om een upgrade uit te voeren. Het gaat om Java versies die ouder zijn dan versie 6 update 51 of versie 7 update 25. Het opstarten van Java code met deze of oudere versies is dan niet meer mogelijk.

Apple de-installeert niet de oudere versie maar zorgt er gewoon voor dat de verouderde versies niet meer opstarten. Websites die Java nodig hebben zullen hierdoor niet of slechts gedeeltelijk functioneren. Gebruikers met nieuwe versies zullen geen enkele hinder ondervinden van deze actie. De minimaal benodigde versie voor Java plug-in voor Snow Leopard is nu 13.9.7 (Java 6 update 51). Op Lion en Mountain Lion is de minimale versie voor de Java plug-in 14.8.0 (dat is Oracle Java 7 update 25). Java zit sinds het uitkomen van Lion niet meer standaard ingebouwd, maar wordt als een third-party software van Oracle aangeboden.

Beveiligingsbedrijf Intego heeft aangegeven dat de update waarschijnlijk te maken heeft met berichten dat exploits voor Java-lekken in de Neutrino-exploitkit zijn verschenen. Met deze kit zou het makkelijker zijn om niet gepatchde Mac- en Windowsgebruikers aan te vallen. De exploitkits zijn echter voornamelijk op Windows gericht.


Om social media te kunnen gebruiken zijn cookies nodig, schakel deze in om de knoppen te activeren.

Tags: , , , , , ,

Close